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Abstract 

Organelle pH homeostasis is crucial for maintaining proper cellular function. The nature of the 

peroxisomal pH remains somewhat controversial, with several studies reporting conflicting results. 

Here, we describe in detail a rapid and accurate method for the measurement of peroxisomal pH, using 

the pHRed sensor protein and confocal microscopy of living mammalian cells. pHRed, a ratiometric 

sensor of pH, is targeted to the peroxisomes by virtue of a C-terminal targeting sequence. The probe 

has a maximum fluorescence emission at 610 nm while exhibiting dual excitation peaks at 440 nm and 

585 nm, allowing for ratiometric imaging and determination of intracellular pH in live cell 

microscopy. 
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1. Introduction 

Intracellular pH homeostasis is crucial for the maintenance of cellular metabolism and signaling. 

Changes in intracellular pH influence membrane potentials as well as protein structure and function, 

affecting many physiological processes in the cell, e.g. ATP production, proliferation, migration, 

vesicular trafficking, apoptosis, DNA and RNA synthesis [1]. Optimal pH is maintained by the 

balance between active H+ pumping and passive H+ efflux. Thus, organelle pH homeostasis is 

sustained within membrane-enclosed compartments through several specialized proton-translocating 

proteins [2]. The nature of the peroxisomal pH has been controversial, with some studies reporting a 

neutral pH, whilst others detected a slightly alkaline pH [3-7]. The peroxisomal pH was first measured 

in mammalian cells by Dansen and co-workers [3]. Making use of the fluorophore SNAFL conjugated 

with a membrane-permeable peptide that contains a type-I peroxisomal targeting sequence (PTS1) the 

authors reported a peroxisomal pH of 8.2±0.3 for human fibroblasts [3]. Shortly after, the pH of 

mammalian peroxisomes was reported by Jankowski and co-workers to be between 6.9 and 7.1, 

resembling the cytosolic pH [5]. In this case, a pH-sensitive mutant of the green fluorescent protein 

(pHluorin) containing the peroxisome-specific carboxyl-terminal targeting sequence (-SKL) was used 

[5]. Even though a possible explanation for the conflicting results might be attributable to specific 

properties of the pH sensors, the existence of differences in peroxisomal pH under different growth 

conditions and in different cell types cannot be excluded. However, it should be noted that the optimal 

pH of most peroxisomal enzymes is between pH 8 and 9 and so it is not unreasonable to assume that 

this reflects the pH of peroxisomes in vivo [4]. Here, we describe a method for the measurement of 

peroxisomal pH in living mammalian cells that uses confocal microscopy and a pHRed sensor targeted 
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to the peroxisome by virtue of a C-terminal peroxisomal targeting signal (-SKL). pHRed was 

engineered by mutagenesis of the red fluorescent protein mKeima and is the first ratiometric single-

protein red fluorescent sensor of pH [8]. Importantly, the pHRed ratio response is insensitive to 

oxidative stress (H2O2), temperature (21-37ºC) and different ion concentrations (K+, Na+, CL-, Mg2+, 

Ca2+, HCO3
-) [8]. The pHRed sensor has bimodal excitation spectra, exhibiting excitation peaks at 440 

nm and 585 nm, which are caused by the protonated neutral chromophore in an alkaline condition and 

the anionic chromophore in an acidic condition, respectively, but exhibits a single fluorescence 

emission peak at 610 nm. The pH can be calculated by measuring the fluorescence intensity ratio 

between excitation peaks (F585/F440) and by comparing it with a calibration curve [8]. In situ 

calibration of the pHRed sensor is achieved by expressing the protein in the cytoplasmic compartment 

of living cells in the presence of different pH calibration solutions containing the ionophore nigericin. 

The method described allows for the measurement of peroxisomal pH in living mammalian cells and 

can be used to determine the modulation of peroxisomal pH, for example after external stimulation of 

peroxisomal metabolism and proliferation, during developmental processes, and in disease conditions.  

 

2. Materials 

 

2.1 Solutions for pH measurements 

1. Calibration solution (250 ml) - Add the following amounts and fill up to 250 ml with 

deionized water: 2.5 g of KCl (135 mM), 0.07 g K2HPO2 (2 mM), 1.19 g HEPES (20 mM), 

0.033 g of CaCl2 (1.2 mM), 0.024 g MgSO4 (0.8 mM). You need to adjust the pH (with 1M 

HCl or 1M KOH) before filling up the volume to 250 ml (see 3.2, step 2). 

2. Nigericin stock solution (10 mM) – dissolve 5 mg of nigericin in 670 µl of absolute EtOH. 

Prepare aliquots and store at -20ºC. 
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3. Complete growth medium: Dulbecco’s modified Eagle medium (DMEM), high glucose (4.5 

g/L) supplemented with 10% FBS, 100 U/ml penicillin and 100 µg/ml streptomycin. 

4. Phosphate-buffered saline (PBS) solution: 9 g NaCl (137 mM), 0.2 g KCl (2.7 mM), 1.42 g 

Na2HPO4 (10 mM), 0.24 g KH2PO4 (1.8 mM). Start with 800 ml deionized water to dissolve 

all salts, then adjust pH to 7.4 with HCl. Add water to a total volume of 1L. 

5. Live cell medium: Dulbecco’s modified Eagle medium (DMEM), high glucose (4.5 g/L), 25 

mM HEPES, no phenol red supplemented with 10% FBS, 100 U/ml penicillin and 100 µg/ml 

streptomycin. 

 

2.2 Plasmids, transfection reagents and cell culture 

1. Genetically encoded red fluorescent protein pHRed was generated by introducing a single 

point mutation into mKeima (A213S) [8]. pHRed was cloned into a mammalian expression 

vector (pcDNA3.1) for cytoplasmic expression (pHRed-Cyto). To target pHRed into the 

peroxisomal matrix, the plasmid pHRed-PO was generated by adding a peroxisomal targeting 

sequence (-SKL) at the C-terminus of pHRed.  

2. Transfection reagents (e.g., Lipofectamine 3000 or electroporation) (see Note 1). 

3.  Human fibroblast cells. 

4. COS-7 (ATCC CRL-1651) cells. 

5. Cell culture dishes, with vents, sterile (100/20 mm; Greiner bio-one). 

6. Glass bottom culture dishes (35/10 mm; Greiner bio-one) 

 

2.3 Equipment for live-cell imaging and acquisition settings 

1. Confocal microscope (Leica SP8 or similar) equipped with: Argon laser 

(458/476/488/496/514), DPSS561 laser (561), HC PL APO CS2 40x/1.3 Oil objective, HC 

PL APO CS2 63x/1.4 Oil objective, Hybrid detectors (HyD). 
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2. Temperature-controlled life cell imaging chamber (159.8 x 109.8 x 26.7 mm, WxHxD) that 

accommodates glass bottom culture dishes (35/10 mm; Greiner bio-one).  

 

3. Methods 

 

3.1 Cell culture 

1. Human fibroblasts and COS-7 cells were maintained in 100/20 mm cell culture dishes 

containing complete growth medium in a 37ºC/5% CO2 incubator.  

2. Cell passaging was performed in a Class II Biological Safety Cabinet/Tissue Culture Hood 

when cells reached 80-90% confluence. The cell culture medium was refreshed every 2-3 

days. 

 

3.2 In situ calibration of pHRed probe 

1. In situ calibration of pHRed fluorescence is performed in order to correlate the ratio data to 

pH values. In a Biological Safety Cabinet/ Tissue Culture Hood, seed cells of interest (here, 

1x105 fibroblasts and COS-7 cells) in five glass bottom culture dishes containing 2 ml of 

complete growth medium. Cells should be 40-50% confluent after 24h incubation in a 

37ºC/5% CO2 incubator. 

2. Prepare calibration solutions with different pH values (here, 5 solutions with pH 6.5, 7.0, 7.5, 

8.0, 8.5), adjust pH by adding HCl (1M) or KOH (1M) (see Note 2). 

3. After 24h transfect cells with pHRed-Cyto construct using the transfection method of choice 

(see Note 1) and incubate cells for 24h in a 37ºC/5% CO2 incubator. 

4. Aspirate the growth medium from the transfected cells and wash cells twice with sterile PBS. 

Then add 2 ml of one of the five calibration solutions containing nigericin (here, 5 µM for 

fibroblasts, and 10 µM for COS-7 cells) (see Note 3). 
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5. Place the culture dish into the confocal stage chamber once it has warmed up to 37ºC and the 

microscope is set up. 

6. Wait for 10-20 min before acquiring images (see Note 4) to assure that the intracellular pH is 

stable and equal to the extracellular pH (pHi = pHe). Acquire images from at least 10-20 cells 

(see Note 5) for each calibration solution (Figure 1). 

7. Repeat steps 4 to 6 for each remaining calibration solution using a new culture dish. 

 

3.3 Measurement of peroxisomal pH 

1. Prepare the glass bottom culture dishes required for the experiment. Here, two glass bottom 

culture dishes were prepared for each cell line.  

2. In a Biological Safety Cabinet/ Tissue Culture Hood, seed cells of interest (here, 1x105 

fibroblasts and COS-7 cells) in glass bottom culture dishes containing 2 ml of complete 

growth medium. Cells should be 40-50% confluent after 24h incubation in a 37ºC/5% CO2 

incubator. 

3.  After 24h transfect cells with pHRed-PO construct using the transfection method of choice 

and incubate cells for another 24-48h (see Note 6) in a 37ºC/5% CO2 incubator. 

4. Aspirate the growth medium from the transfected cells and wash cells twice with sterile 

PBS. Then add 2 ml of HEPES-buffered live cell medium.  

5. Place the culture dish into the confocal stage chamber once it has warmed up to 37ºC. 

6. Collect images from at least 10-20 cells per condition used (Figure 2). 

 

3.4  Image acquisition 

1. After locating the cell you intend to image, set up two virtual channel scans on the 

microscope imaging software (see Note 7). 

2. Set the first channel to Argon excitation 458 nm and emission collection 600-620 nm. 
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3. Set the second channel to DPSS561 excitation 561 nm and emission collection 600-620nm. 

4. For image collection of cytosolic pHRed (pHRed-Cyto) the HC PL APO CS2 40x/1.3 Oil 

objective was used due to the large size of the cells. For detection of peroxisomal pHRed 

(pHRed-PO) the HC PL APO CS2 63x/1.4 Oil objective was used. 

5. Fluorescence intensities are obtained on a 12-bit numerical scale (0-4.095 gray level scale). 

 

3.5 Image processing for calibration curve 

1. Image processing is described for the open access image analysis software ImageJ. 

Alternatively any other appropriate software can be applied. 

2. After acquiring the images from the calibration measurements, convert to 32-bit image 

(Image>Type>32-bit). 

3. Set lower and upper threshold for both channels (Image>Adjust>Threshold...) (see Note 

8). The cell area should be marked with a red stain whereas the background remains largely 

black. Once you apply the threshold, a box “NaN background” will appear with the “Set 

Background Pixels to NaN” selected, press “OK”.  

4. Digitally divide the image with fluorescence intensity 561 nm by the fluorescence intensity 

458 nm (Process>Image Calculator). Select the 32-bit (float) result box. The resulting new 

window shows the ratio 561/458 nm image. 

5. To quantify the data, first select the area of the cell with one of the selections tools (e.g. 

rectangular, oval, polygon or freehand) and obtain the mean ratio in the selected area 

(Analyze>Measure). The results of each measurement will appear in the “Result” window. 

6. Export the data to Excel and plot the data using scientific graphing software (e.g., Excel or 

GraphPad). The plot should portray fluorescence ratios (Y-axis) as a function of pH (X-

axis). Curve fitting is achieved using non-linear regression (Figure 1). 

7. Use calibration curve equation to transform ratios into pH values. 
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3.6 Image processing for determination of peroxisomal pH 

1. Use ImageJ and open images with corresponding fluorescence signals (Figure 2). 

2. Use image from fluorescence intensity 458 to generate a binary mask (Figure 2) by 

duplicating the original image and applying a threshold (Image>Adjust>Threshold…) (see 

Note 8). 

3. Subtract 254 grey values from each pixel of the 8-bit binary mask 

(Process>Math>Subtract). 

4. Digitally subtract the background fluorescence from both fluorescence images using the 

rolling ball background subtraction function (Process>Subtract Background) (see Note 9). 

5. Digitally divide the image with fluorescence intensity 561 nm by the fluorescence intensity 

458 nm (Process>Image Calculator). Select the 32-bit (float) result box. 

6. Multiply the resulting image with the previously generated binary mask using the same 

Image Calculator command. This will create the ratio image (Figure 2). 

7. For selecting the regions of interest (peroxisomes) first adjust the grey value of the binary 

mask to 0 (Image>Adjust>Brightness/Contrast). 

8. Run Analyze particles command to obtain the peroxisome regions (Analyze>Analyze 

particles) (see Note 10). 

9. Open the ratio image and overlay the peroxisome regions of interest (ROIs) using the ROI 

manager and press the measure button. The results of the ratios per peroxisome will appear 

in the results window, then copy paste into a spreadsheet.  

10. Using the formula obtained from the calibration curve convert the ratio values into pH 

values. 
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11. Alternatively, the generated ratio image can be converted to a pH image (Figure 2) by 

inserting the equation obtained from the calibration curve (Process>Math>Macro) (see 

Note 11). 

 

4. Notes 

1. Primary cells such as patient skin fibroblast are difficult to transfect, but high transfection 

rates have been achieved by microporation (see this issue). Other mammalian cells (e.g. 

COS-7 cells) can be transfected by PEI, lipofection or electroporation. 

2. We recommend using at least 5 calibration solutions with different pH values in order to 

generate the calibration curve. If desired more calibration solutions can be used between 

pH 5.5 and 9 [8]. 

3. After preparing the nigericin stock solution (10 mM), it is recommended to prepare 

aliquots which can be stored at -20ºC. Nigericin can be added to the calibration solution 

(stable for 1 month at 4ºC) or after the calibration solution has been added to the culture 

dish. Nigericin final concentration (5-20 µM) depends on the cell type being used and 

requires optimization to minimize cell death [9]. 

4. Nigericin is a K+/H+-ionophore that increases cell membrane permeability when added to 

living cells in the presence of buffer with high extracellular KCl. It causes equilibration of 

intracellular and extracellular pH (pHi = pHe) [9]. 

5. We recommend imaging of 15-20 cells to ensure that the calculated mean is accurate [10]. 

6. Longer incubation times allow a more efficient import of the pHRed-PO into peroxisomes, 

reducing the cytoplasmic pool. 

7. The fluorescence excitation and emission spectra of purified pHRed in solution allows for 

some flexibility when setting the fluorescence acquisition software [8]. Recommended first 

phase excitation range 420-460 nm, second phase excitation range 560-580 nm. 
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8. For coherency, it is recommended to choose one of the predefined threshold algorithms 

available in ImageJ and apply to all images. Remember to have the dark background 

option selected. 

9. Before using the rolling ball background subtraction function, the image display can be 

changed to HiLo LUT (Image>Lookup Tabels> HiLo) so the zero pixel values are 

displayed as blue and other pixel values are displayed in grey. Then try different rolling 

ball pixel values to determine which one gives a better background correction. 

10. When using the analyze particles tool make sure the following parameters are selected: 

display results and add to manager. Also, the size of the particle can be adjusted to remove 

smaller objects. 

11. The equation formula format: v=(log(v)-log(α))/-β (the α and β values are obtained from 

the curve fitting) . Once the formula is applied remove the pixel values with the value 

NaNs (Process>Noise>Remove NaNs…) (Figure 2). Then change the image background 

to black and add the calibration bar (Analyze>Tools>Calibration Bar…) (Figure 2). 
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Figure legends 

 

Figure 1. In situ calibration of pHRed. (A) Representative images of F458 and F561 pHRed sensor 

expressed in the cytoplasm of human skin fibroblasts. (B) Calibration curve portrays fluorescence 
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ratios (Y-axis) for pHRed-Cyto determined using the calibration solutions as a function of pH (X-

axis). Bar, 20 µm. 

 

Figure 2. Peroxisomal pH measurements using ImageJ. Representative images of (A) F458 and (B) 

F561 pHRed-PO sensor targeted to the peroxisomal matrix in human skin fibroblasts. (C) Binary mask 

obtained after applying threshold to image F458. (D) Ratio image. (E) Equation image obtained after 

applying the calibration formula to the ratio image. (F) pH image with calibration bar. (G) Box-plot 

and whiskers graph showing pH values recorded in the cytosol and peroxisome compartment of 

human skin fibroblasts (mean pHcytosol = 7.1±0.3; mean pHPO = 7.4±0.5) and COS-7 cells (mean 

pHcytosol = 7.4±0.3; mean pHPO = 8.1±0.45) under normal growth conditions. Note that the peroxisomal 

pH is more alkaline than the cytosolic pH. Peroxisomal subpopulations with different pH may exist. 

The peroxisomal pH may depend on metabolic activity, cell culture conditions and cell type-specific 

properties. Bar, 10 µm.  

 


